PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from t
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.2.1, 4.2.4, 5.3.1, 8.1.7, 2.0.2, and 3 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, as demonstrated by (1) an application that makes a getenv('HTTP_PROXY') call or (2) a CGI configuration of PHP, aka an "httpoxy" issue.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
- guzzlehttp/guzzlePackagist
From 6 · fixed in 6.2.1
- guzzlehttp/guzzlePackagist
From 4.0.0-rc2 · fixed in 4.2.4
- guzzlehttp/guzzlePackagist
From 5 · fixed in 5.3.1
- drupal/corePackagist
From 8.0 · fixed in 8.1.7
- bugsnag/bugsnag-laravelPackagist
fixed in 2.0.2
- amphp/artaxPackagist
fixed in 1.0.4
- amphp/artaxPackagist
From 2.0.0 · fixed in 2.0.4
- padraic/humbug_get_contentsPackagist
fixed in 1.1.2