Skip to main content
← All vulnerabilities
CVE-2016-5016GHSA-RC2R-W8JV-VGGP

Pivotal Cloud Foundry 239 and earlier, UAA (aka User Account and Authentication Server) 3.4.1 and earlier, UAA release 12.2 and earlier, PCF

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.3.0.3, 3.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

Pivotal Cloud Foundry 239 and earlier, UAA (aka User Account and Authentication Server) 3.4.1 and earlier, UAA release 12.2 and earlier, PCF (aka Pivotal Cloud Foundry) Elastic Runtime 1.6.x before 1.6.35, and PCF Elastic Runtime 1.7.x before 1.7.13 does not validate if a certificate is expired.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.cloudfoundry.identity:cloudfoundry-identity-serverMaven

    From 3.0.0 · fixed in 3.3.0.3

  • org.cloudfoundry.identity:cloudfoundry-identity-serverMaven

    From 3.4.0 · fixed in 3.4.2

References 7

GitHub · cloudfoundry/uaa

GitHub · cloudfoundry/uaa-release

GitHub · cloudfoundry/cf-release

pivotal.io