Skip to main content
← All vulnerabilities
CVE-2016-4428GHSA-GRM6-X6MR-Q3CVPYSEC-2026-643

Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authentica

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.0.2, 9.1.0
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • horizonPyPI

    fixed in 8.0.2

  • horizonPyPI

    From 9.0.0 · fixed in 9.1.0

  • horizonPyPI

    fixed in 8.0.2; From 9.0.0 · fixed in 9.1.0

References 12

access.redhat.com

debian.org

security.openstack.org

review.openstack.org

bugs.launchpad.net

openwall.com