Skip to main content
← All vulnerabilities
CVE-2016-4003GHSA-M3X6-9V6H-4G28

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x before 2.3.28, when usin

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.28
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x before 2.3.28, when using a single byte page encoding, allows remote attackers to inject arbitrary web script or HTML via multi-byte characters in a url-encoded parameter.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.struts:struts2-coreMaven

    From 2.0.0 · fixed in 2.3.28

References 4

struts.apache.org

securityfocus.com

securitytracker.com

issues.apache.org