Skip to main content
← All vulnerabilities
CVE-2016-3734GHSA-R867-V437-4RRM

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 thr

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.14, 2.8.12, 2.9.6, 3.0.4
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.7.14

  • moodle/moodlePackagist

    From 2.8 · fixed in 2.8.12

  • moodle/moodlePackagist

    From 2.9 · fixed in 2.9.6

  • moodle/moodlePackagist

    From 3.0 · fixed in 3.0.4

References 5

openwall.com

git.moodle.org

bugzilla.redhat.com

securitytracker.com

securityfocus.com