CVE-2016-3169GHSA-Q3P9-8728-WQ7X
The User module in Drupal 6.x before 6.38 and 7.x before 7.43 allows remote attackers to gain privileges by leveraging contributed or custom
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.38, 7.43
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The User module in Drupal 6.x before 6.38 and 7.x before 7.43 allows remote attackers to gain privileges by leveraging contributed or custom code that calls the user_save function with an explicit category and loads all roles into the array.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- drupal/corePackagist
From 6.0 · fixed in 6.38
- drupal/corePackagist
From 7.0 · fixed in 7.43
- drupal/drupalPackagist
From 7.0 · fixed in 7.43
- drupal/drupalPackagist
From 6.0 · fixed in 6.38