Skip to main content
← All vulnerabilities
CVE-2016-3166GHSA-FG5Q-R2Q5-QMH3

CRLF injection vulnerability in the drupal_set_header function in Drupal 6.x before 6.38, when used with PHP before 5.1.2, allows remote att

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.38
None on Exploit-DB, Metasploit or GitHub

Summary

CRLF injection vulnerability in the drupal_set_header function in Drupal 6.x before 6.38, when used with PHP before 5.1.2, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks by leveraging a module that allows user-submitted data to appear in HTTP headers.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • drupal/corePackagist

    From 6.0 · fixed in 6.38

  • drupal/drupalPackagist

    From 6.0 · fixed in 6.38

References 4

openwall.com

debian.org

drupal.org