Skip to main content
← All vulnerabilities
CVE-2016-2785GHSA-PQJ5-7R86-64FV

Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet Agent before 1.4.2 might allow remote attackers to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet Agent before 1.4.2 might allow remote attackers to bypass intended auth.conf access restrictions by leveraging incorrect URL decoding.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    From 4.0.0 · fixed in 4.4.2

References 3

security.gentoo.org

GitHub · puppetlabs/puppet

puppet.com