Skip to main content
← All vulnerabilities
CVE-2016-2190GHSA-R9PC-G29W-F86J

Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not properly restrict links

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.13, 2.8.11, 2.9.5, 3.0.3
None on Exploit-DB, Metasploit or GitHub

Summary

Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not properly restrict links, which allows remote attackers to obtain sensitive URL information by reading a Referer log.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    through 2.6.11

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.13

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.11

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.5

  • moodle/moodlePackagist

    From 3.0.0 · fixed in 3.0.3

References 4

openwall.com

git.moodle.org

moodle.org

securitytracker.com