Skip to main content
← All vulnerabilities
CVE-2016-2162GHSA-2J4Q-9FFF-236J

Apache Struts 2.x before 2.3.25 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote attacke

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.28
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Struts 2.x before 2.3.25 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors involving language display.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.struts:struts2-coreMaven

    From 2.0.0 · fixed in 2.3.28

References 3

securitytracker.com

securityfocus.com

struts.apache.org