Skip to main content
← All vulnerabilities
CVE-2016-2157GHSA-F5PM-C4CW-563P

Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x be

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.13, 2.8.11, 2.9.5, 3.0.3
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote attackers to hijack the authentication of administrators for requests that manage Assignment plugins.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.7.13

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.11

  • moodle/moodlePackagist

    From 2.9.0 · fixed in 2.9.5

  • moodle/moodlePackagist

    From 3.0.0 · fixed in 3.0.3

References 4

openwall.com

git.moodle.org

moodle.org

securitytracker.com