Skip to main content
← All vulnerabilities
CVE-2016-2152GHSA-6MXM-WPQV-675H

Multiple cross-site scripting (XSS) vulnerabilities in auth/db/auth.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11,

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.13, 2.8.11, 2.9.5, 3.0.3
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site scripting (XSS) vulnerabilities in auth/db/auth.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allow remote attackers to inject arbitrary web script or HTML via an external DB profile field.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.7 · fixed in 2.7.13

  • moodle/moodlePackagist

    From 2.8 · fixed in 2.8.11

  • moodle/moodlePackagist

    From 2.9 · fixed in 2.9.5

  • moodle/moodlePackagist

    From 3.0 · fixed in 3.0.3

References 4

git.moodle.org

openwall.com

moodle.org

securitytracker.com