CVE-2016-2098GHSA-78RC-8C29-P45G
Action Pack in Ruby on Rails before 3.2.22.2, 4.x before 4.1.14.2, and 4.2.x before 4.2.5.2 allows remote attackers to execute arbitrary Rub
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.2.22.2, 4.1.14.2, 4.2.5.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB, 1 Metasploit module, 12 proofs of concept on GitHub
Summary
Action Pack in Ruby on Rails before 3.2.22.2, 4.x before 4.1.14.2, and 4.2.x before 4.2.5.2 allows remote attackers to execute arbitrary Ruby code by leveraging an application's unrestricted use of the render method.
Timeline
- CVE published
- Public exploit on Exploit-DB
EDB-40086
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
- actionpackRubyGems
From 3.0.0 · fixed in 3.2.22.2
- actionpackRubyGems
From 4.0.0 · fixed in 4.1.14.2
- actionpackRubyGems
From 4.2.0 · fixed in 4.2.5.2