Skip to main content
← All vulnerabilities
CVE-2016-2041GHSA-8M97-XC46-RW9W

libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time al

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.10.13, 4.4.15.3, 4.5.4
None on Exploit-DB, Metasploit or GitHub

Summary

libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • phpmyadmin/phpmyadminPackagist

    From 4.0 · fixed in 4.0.10.13

  • phpmyadmin/phpmyadminPackagist

    From 4.4 · fixed in 4.4.15.3

  • phpmyadmin/phpmyadminPackagist

    From 4.5 · fixed in 4.5.4

References 7

lists.opensuse.org

debian.org

phpmyadmin.net

GitHub · phpmyadmin/phpmyadmin

lists.fedoraproject.org