CVE-2016-1902GHSA-JJX5-FQ5G-8XPC
The nextBytes function in the SecureRandom class in Symfony before 2.3.37, 2.6.x before 2.6.13, and 2.7.x before 2.7.9 does not properly gen
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.6.13, 2.7.9, 2.3.37
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The nextBytes function in the SecureRandom class in Symfony before 2.3.37, 2.6.x before 2.6.13, and 2.7.x before 2.7.9 does not properly generate random numbers when used with PHP 5.x without the paragonie/random_compat library and the openssl_random_pseudo_bytes function fails, which makes it easier for attackers to defeat cryptographic protection mechanisms via unspecified vectors.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- symfony/security-corePackagist
From 2.4.0 · fixed in 2.6.13
- symfony/security-corePackagist
From 2.7.0 · fixed in 2.7.9
- symfony/securityPackagist
From 2.3.0 · fixed in 2.3.37
- symfony/securityPackagist
From 2.4.0 · fixed in 2.6.13
- symfony/securityPackagist
From 2.7.0 · fixed in 2.7.9
- symfony/symfonyPackagist
From 2.3.0 · fixed in 2.3.37
- symfony/symfonyPackagist
From 2.4.0 · fixed in 2.6.13
- symfony/symfonyPackagist
From 2.7.0 · fixed in 2.7.9