CVE-2016-10534GHSA-Q43M-FFWR-RPCC
electron-packager is a command line tool that packages Electron source code into `.app` and `.exe` packages.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 7.0.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
electron-packager is a command line tool that packages Electron source code into `.app` and `.exe` packages. along with Electron. The `--strict-ssl` command line option in electron-packager >= 5.2.1 <= 6.0.0 || >=6.0.0 <= 6.0.2 defaults to false if not explicitly set to true. This could allow an attacker to perform a man in the middle attack.
Timeline
- CVE published
- Record last updated
Affected versions
- HackerOne electron-packager node module
>= 5.2.1 <= 6.0.0 || >=6.0.0 <= 6.0.2
- electron-packagernpm
From 5.2.1 · fixed in 7.0.0