CVE-2016-10523GHSA-G3R2-65GC-QPQC
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible wit
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.4.6, 4.0.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
Timeline
- CVE published
- Record last updated
Affected versions
- HackerOne mqtt-packet node module
<3.4.6 || > 4.0.0 <4.0.5
- mqtt-packetnpm
fixed in 3.4.6
- mqtt-packetnpm
From 4.0.0 · fixed in 4.0.5