Skip to main content
← All vulnerabilities
CVE-2016-0785GHSA-876P-4WGC-75RX

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.20.3, 2.3.24.3
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.struts:struts2-coreMaven

    From 2.0.0 · fixed in 2.3.20.3

  • org.apache.struts:struts2-coreMaven

    From 2.3.24 · fixed in 2.3.24.3

References 3

securitytracker.com

struts.apache.org

securityfocus.com